Mittwoch, 21. Januar 2009

SocketException ErrorCode 10035 – Ein Switch war dran schuld!

tahoe-ii Ein Kunde hat ein Problem mit dem .NET Micro Framework und einem Tahoe-II Board. In einem Beispielprojekt wird auf einen Web Server zugegriffen, um den HTML Quelltext herunterzuladen, eigentlich eine ganz einfache Aufgabe. Im Microsoft Emulator als auch in den Tahoe/Tahoe-II Emulatoren klappt das alles einwandfrei, nur eben nicht mit der echten Hardware. Folgenden Fehler zeigt das Visual Studio bei socket.Connect():

#### Exception System.Net.Sockets.SocketException - E_FAIL (1) ####
#### Microsoft.SPOT.Net.SocketNative::poll [IP: 0000] ####
#### System.Net.Sockets.Socket::Poll [IP: 0011] ####
#### System.Net.Sockets.Socket::Connect [IP: 0029] ####
#### NetworkTester.Program::Main [IP: 00f7] ####
#### SocketException ErrorCode = 10035
Eine Ausnahme (erste Chance) des Typs "System.Net.Sockets.SocketException" ist in Microsoft.SPOT.Net.dll aufgetreten.
#### SocketException ErrorCode = 10035
#### SocketException ErrorCode = 10035
#### SocketException ErrorCode = 10035
SocketException: Exception was thrown: System.Net.Sockets.SocketException Error-code: 10035
Der Thread 0x1 hat mit Code 0 (0x0) geendet.
Das Programm "[13] Micro Framework application: Verwaltet" wurde mit Code 0 (0x0) beendet.

Das gleiche Beispielprojekt läuft bei mir aber einwandfrei. Nach ein paar anderen Tests haben wir’s dann doch noch gefunden, es lag am Switch, an dem das Tahoe-II Board angeschlossen war. Da die Boards nur einen 10 MBit Anschluss haben, könnte es auch an der Erkennung als 10 MBit liegen. Switch durch einen anderen ausgetaucht, und schon klappt alles.

Keine Kommentare:

Kommentar veröffentlichen